Foram Trieur

  1. Home
  2. Foram Trieur
  3. Quick Start

Quick Start

This documentation is still being written.

This section gives an overview of how to begin classifying images. In particular:

  • Starting a new project
  • Classifying some images
  • Exporting the results

Follow the links for more details

Starting A Project

Use File → New from Template to create a project based off an existing project.
Use Edit → Add Images… to add images from both files and directories, and to extract parameters from their filenames.
The Save button will turn red to indicate the project needs saving.
  1. Open ForamTrieur and click the New button to start a blank project.
  2. Click the + button at the bottom-left of the window and select the foraminifera images you wish

The screen will look something like:

The program is laid out in three sections:

Table

Press Ctrl / Command + A to select all images.
Hold Shift to select a block of images.
Hold Ctrl / Command to select multiple images individually.

On the left is a table with a list of images in the project and their parameters such as Class, Tag, Depth and Core ID.

  • Change the currently selected image by clicking or using the keyboard arrows.
  • Sort by parameter by clicking the column header (ascending, descending, none).
  • Type in the text box above the table to filter by class.
  • Click >> or drag the vertical divider at the right of the table to expand it.
  • Click Edit → Edit Selected Forams… to change the minimum depth, maximum depth, and core ID of the selected images.

Image

The pre-processed version of the image will be shown after clicking Classify.

The middle section of the program shows the currently selected image.

  • The current class of the image is shown in white text.
  • The filename, image size and index are shown below the image.
  • Click Previous / Next to go back / advance through the images.

Processing

On the right there are two tabs, Classification and Morphology. These are explained in the next section.

Sorting Images

One the images have been added to the project, the next step is to classify, tag, rate and add metadata to them.

Classification, Tagging, Rating

Press keys 1-9, 0 to assign the class corresponding to the 1st to 10th buttons, respectively.
Right click a class button to show more information, and to set a value when using multi-class labelling.

The classification tab contains three sets of buttons: Morphotypes, Other and Tags, along with a image quality rating.

Morphotypes and Other contain buttons corresponding to classes. The code of the class is displayed on the button.

  • Clicking a button will assign that class to the image, removing all others.
  • The classes can be edited by clicking Edit → Edit Classes…
  • The unlabeled and other classes are mandatory. Unlabeled is the default class for newly added images.
Prefix the term in the filter box by tag: or rating: to filter by tag or rating, respectively.

Multiple tags can be assigned to an image.

  • Click a tag button to assign it, click again to unassign.
  • The tags can be edited by clicking Edit → Edit Tags…

The image can also be given a quality rating by clicking the stars.

Metadata

Each image is associated with depth and core ID metadata.

  • Core ID is a reference to which core the images are from. Typically one should use a different project for each core.
  • Depth minimum and maximum are the depth down core from where the sample was taken. The depth value is used to visualise the core statistics, such as relative abundance.

To change the values:

  • Click >> to expand the table to the whole window.
  • Select the images whose metadata is to be changed.
  • Click Edit → Edit Selected Forams… and enter the new values.

Morphology

The morphology tab shows measurements of the shape and intensity distribution of the image. To perform these calculations, the particle in the image must be segmented from the background. Segmentation is performed by thresholding the image intensity (the background is usually darker) with some further processing steps (hole removal and smoothing).

  • Use the Threshold Adjustment slider to adjust the segmentation threshold.
  • Tick Use Otsu’s method for segmentation to use an adaptive threshold.
  • Tick Show Outline to show the segmentation boundary as a blue line.

To help with labelling the images, they can be sorted by the morphological measurement under Operations → Sort by Morphology or by the similarity to the currently selected image using Operations → Sort by Similarity → Morphology.

Morphology is not automatically calculated for all images, as it takes a lot of time. Before sorting for the first time, or if sorting after changing the segmentation settings, run Operations → Calculate Morphology to update the measurements.

Saving

The project and images can be shared with other people, so long as the project XML file and the images have the same relative path on disk. For example, if the project XML is in the parent folder of the images, it can be moved to another location on disk so long as it is still in the parent folder of the images.

As the program is still in beta, it is a good idea to regularly save the project file in case a bug is encountered. To do this:

  • Click File → Save and enter a project name.

The project information is saved in an XML file in plain text format.

It is recommended to layout the project structure as follows:

PROJECT_FOLDER
-> project.xml
-> images
   -> image001.png
   -> image002.png
   -> ...

Export

The labelled images and morphometric images can also be exported.

  • Exporting images saves the images to a new directory.
  • The names of the images are changed to include the class and metadata.
  • The images can be sorted into sub-directories based on depth or class.
  • The images can be optionally pre-processed (segmentation, rotation, normalisation).
  • A project file is created for the exported images.

Click File → Export → Images… to start the export process.

The morphology for each image, along with its metadata, can also be exported to CSV.

  • Click File → Export → Morphology to CSV… to start the export process.

Next Steps

Some other useful features of the program are:

  • Add images and extract depth, class or core ID information from their filenames.
  • Classify images using  a TensorFlow neural network.
  • Automatically watch a folder for new images and add them to the project. (IN DEVELOPMENT)
  • Perform simple segmentation of slides with multiple particles.

How can we help?